[Load Balancer] DNS proxy request



  • Hi,

    I just bought your product and trying to configure it.
    I am running it on smartos zone ( at least that works already) and trying to configure it as reverse proxy server for my dns servers. But the doc and the example is not so clear i have 3 dns servers running and want to loadbalance them thru you product but its not 100% clear so is there a way to have some examples it would be good
    Once i have this i can do some benchmarking on it also have several things that i want to loadbalance.
    Regards
    Filip



  • Hi FilipFramcis and welcome to Honeyside!

    To load balance requests you will have to set up a server in your config.js file like this:

    servers: {
      "yourdomain.com": [
        {
          balance: ["http://thisisanurl", "http://thisisanotherurl", "http://thirdurl"]
        }
      ]
    }
    

    Please note that Acacia has never been tested for DNS proxy, up to now. We will run some tests and let you know. This feature may require a source code update, if so we will send you the fix as soon as we have it, before uploading it to CodeCanyon 🙂



  • Hi,

    thanks will give it try this evening.
    So with what loadbalacing test did you do then only with http and https.
    as dns is port 53 of course
    Regards
    Filip



  • Hi FilipFramcis,

    Our tests show that a DNS proxy requires changes on our side. We are working on those changes and we will send you soon the updated source via email. Could you ping us at support@honeyside.cc, attaching your license from CodeCanyon?

    Thank you!



  • Hi,

    just send the license to you
    Very impressed by the response time if we can make this product to do reverse proxy for everything that you have a very good candidate replace something like NGINGX what i also want to checkout is the integration with Letsencrypt

    Regards
    Filip



  • Hi FilipFramcis,

    DNS proxy is now supported, starting from Acacia v1.1.0. I just sent you the updated source code via email.

    In order to quickly load balance DNS requests, use the following configuration:

    {
      standard: [...],
      ssl: [...],
      dns: ['8.8.8.8', '8.8.4.4'],
      servers: {...}
    }
    

    This will start a DNS proxy server on port 53 (default). You can test with nslookup.

    To change port and other settings, please have a look at Acacia v1.1.0 documentation.

    You will find the full updated documentation, with the DNS section at https://docs.honeyside.cc/acacia/

    Have a sweet day! 🍯



  • Hi,

    thanks will try this new version tonight ( not at home for the moment)
    Thanks for quick response
    Filip



  • Hi,

    Ok did some testing saw that you have created version 1.2
    so upgraded to this version.
    Now when i add the following in config.js
    dns: [
    {
    port: 53,
    host: 'x.x.x.x',
    nameservers: [
    'dns00',
    'dns01',
    'dns02'
    ],
    }
    ],

    It will not resolv it will bind to port 127.0.0.1 but that is not what i want i want it to bind to the ipaddress of the zone.
    So even if i put
    dns: [ 'dns00', 'dns01' ], it will only bind to localhost
    So how do i get it to bind to the zone ip address
    REgards
    Filip



  • Hi again!

    I am not sure I understand what you mean by "bind to localhost" or "bind to 127.0.0.1".

    The DNS proxy server will be listening on a port. If the port is closed, it will only be reachable from localhost or 127.0.0.1. If you open the port (changing the firewall rules of the firewall you are using), you will be able to reach the DNS proxy from outside.

    The external IP address will be the IP address of your machine or of your router (if you are behind a NAT). If you are behind a NAT, you will need to enable port forwarding on your router.

    This is most probably a configuration issue with your firewall or your router, if I understood correctly. Please check your firewall and your router for the port forwarding issue. Also, make sure you have a public IPv4 enabled from your ISP. Public IPv4 is required for a DNS server to work!

    Please note that we will close for summer vacation for a week, starting from tomorrow. Allow up to 72 hours response delay, starting from now.

    Have a sweet day! 🐝


Log in to reply